
 بسمه تعالی

 

 

 دانشگاه صنعتی شريف

مهندسی مکانیکدانشکده  – برقدانشكده مهندسی   

 

 آردوينو

  معرفی و آموزش نحوه راه اندازی

 

 

 آردوينو چیست ؟



                 الکترونیک کاربردی                              معرفی و نحوه راه اندازی     : آردوینو 

 اکبری: تنظیم                                                         

آردوینو در حقیقت یک بستر سخت افزاری و نرم افزاری برای 

پیاده سازی بردهای الکترونیکی متنوع است که هدف اصلی آن 

ها بوده و به صورت کاملا آسان کردن ساخت بردها و کدنویسی آن

open-source  آردوینو با . در اختیار عموم قرار گرفته است

های کاربردی و نیز ساخت یک آماده ساختن بسیاری از ماژول

بستر کدنویسی ساده و روان ، یک طراح الکترونیک را از 

های کشیهای اولیه و سیماندازیهای اضافی مثل راهپیچیدگی

-ی مورد احتیاج برنامهتمام توابع پایه زیاد و یا نوشتن

-ها از ماژولانواع ماژول. کند نیاز مینویسی سخت افزار بی

های ساده فقط برای راه اندازی میکروکنترلر گرفته تا 

ی وای فای در شیلدهای درایو موتور و حتی اتصال به شبکه

تواند به آردوینو بصورت از پیش طراحی شده موجود است که می

همچنین کد نویسی برای آردوینو . های شما اضافه شود وژهپر

باشد و در می ++Cبه زبان آردوینو است که بسیار مشابه زبان 

محیط کامپایلر آردوینو قابل کامپایل و پروگرام کردن روی 

ی بسیار قابل توجه در مورد آن این است که برد است و نکته

کد زدن شامل توابع ای مورد نیاز در بسیاری از توابع پایه

و یا توابع کار با زمان و نیز ... ریاضی مثل سینوس و 

توابع کار با امکانات جانبی میکرو مثل مبدل آنالوگ به 

در آن با سادگی بسیار زیاد ... دیجیتال یا پورت سریال و

حتی بسیار ساده تر از محیطی مثل کدویژن پیاده سازی شده 

م کدنویسی را به شدت کاهش است که این امر راحتی و نیز حج

 .دهدمی

در ادامه ابتدا به معرفی تنها یکی از بردهای نسبتاً 

پرکاربرد آردوینو که در دو آزمایش مطرح شده در درس 

پردازیم ، سپس محیط الکترونیک کاربردی استفاده خواهد شد می
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و مقدمات کدنویسی در بستر آردوینو را مورد بررسی قرار 

 .دهیممی

  :رکت آردوینو سایت ش

  http://arduino.cc  http://arduino.ir     

 : Arduino Unoبرد 

 

می  ATmega328  یک میکروکنترلر بر پایه Uno برد آردوینو

را دانلود کنید و نگاهی اجمالی بر  ATmega328دیتا شیت )باشد

در حقیقت این برد چیزی جز یک میکروکنترلر . (آن بیندازید

ATmega328 اندازی میکرو ساده نیست که تنها در آن کار راه

اندازی مثل نوسان  شده و مدارات جانبی مورد نیاز برای راه

پیاده سازی شده است و استفاده ... ساز ، مدار ریست و 

اندازی راه زمان بر براینده هیچ درگیری برای عملیات کن

های مختلف میکرو در قالب دو هدر در دو پین. میکرو ندارد

 41این برد  .طرف برد به راحتی در دسترس قرار گرفته است

تای آن می تواند به  6که )جیتال پین ورودی و خروجی دی

-نوسانورودی آنالوگ، یک  6، (ردداستفاده گ PWM عنوان خروجی

، یک USB ، یک پورت( به عنوان کلاک) مگاهرتز46سرامیکی  ساز

و یک دکمه ریست  ICSP header ، یک(ورودی منبع تغذیه)پاورجک 

شامل کلیه امکانات مورد نیاز جهت بکارگیری  Uno برد. دارد

http://arduino.cc/
http://arduino.ir/
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برای شروع تنها . یکروکنترلر موجود بر روی برد می باشدم

، به سـادگی برد را به کامپیوترتان متصـل USB با یک کابل

و یا باتری راه  AC-To-DC کنید و یـا آن را با یـک آداپـتور

کار  USBما در این دو آزمایش فقط با پورت .اندازی نمایید

-این اتصال هم به عنوان منبع تغذیه برد  کار می.خواهیم کرد

 . دهدکند و هم پروگرام کردن را به راحتی انجام می

 

 خلاصه

ATmega823 میکروکنترلر 

 ولتاژ عملیاتی ولت 5

ولتاژ ورودی  ولت 7-22

 (پیشنهادی)

 (محدوده)ولتاژ ورودی  ولت 6-22

پین های دیجیتال  .(استفاده می شود PWMتای آن به عنوان خروجی  6) 21

 خروجی/ورودی

 پین های ورودی آنالوگ 6

هر پین  DCجریان  میلی آمپر 12

 ورودی و خروجی

جهت پین  DCجریان  میلی آمپر 52

3.3V- پین تغذیه 

از آن  کیلوبايت 2.0 که( ATmega823)  کیلوبايت 82

 .قرار می گیرد BootLoaderمورد استفاده 

 حافظه فلش

 SRAM (ATmega823) کیلوبايت 2

 EEPROM (ATmega823) کیلوبايت 2

 سرعت ساعت مگاهرتز 26
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 :های ورودی و خروجی پین

می تواند با استفاده از  Unoپین دیجیتال  41هریک از 

به عنوان ورودی یا  ()pinMode()،digitalWrite()، digitalRead توابع

ولت بوده و ظرفیت  5ولتاز پین ها . خروجی استفاده شود

ن هر همچنی. میلی آمپر می باشد 14جریان جهت هر پین حداکثر 

( کیلواهم 04-54)یک از این پین ها دارای یک مقاومت داخلی 

 (. که به صورت پیش فرض غیرفعال است)می باشد  Pull-Upجهت 

بعلاوه بعضی از پین ها دارای عملکردهای منحصر به فردی می 

 :باشند که شرح آن در ذیل آمده است

  Serial - (RX) 0 و (TX) 1 :  پینRX  برای دریافت وTX  جهت

استفاده  TTLانتقال اطلاعات به صورت سریال و با پروتکل 

 .می شود

  External interrupts (وقفه های خارجی )- این پین ها  :3و  0

می توانند طوری تنظیم شوند که یک وقفه را براساس 

اندکی افزایش یا کاهش لبه، و یا هر نوع تغییر در 

، برای جزئیات بیشتر. مقدار، ایجاد نمایند

 .را مشاهده نمایید ()attachInterrupt تابع

 44 ,44 ,9 ,6 ,5 ,3-  PWM :  امکان دسترسی به یک

هشت بیتی را با استفاده از  PWMخروجی 

 .فراهم می کنند ite()analogWr تابع

 SPI – 10(SS) ،11(MOSI) ،12(MISO)  ،13(SCK) :  با استفاده از

این پین ها می توانند یک  SPIتوابع کتابخانه ای 

یک پروتوکل ارتباط  SPI).ایجاد نمایند SPI library ارتباط

http://arduino.cc/en/Reference/PinMode
http://arduino.cc/en/Reference/DigitalWrite
http://arduino.cc/en/Reference/DigitalRead
http://arduino.cc/en/Reference/AttachInterrupt
http://arduino.cc/en/Reference/AnalogWrite
http://arduino.cc/en/Reference/SPI
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میکروی دیگر یا سایر وسایل سریال برای اتصال میکرو به 

 (جانبی است

  LED – 43:  یکLED  متصل شده  43آماده، به پین دیجیتال

روشن  LEDقرار دارد،  HIGHهنگامی که پین در حالت . است

 .قرار دارد، خاموش می شود LOWو زمانی که پین در حالت 

 Uno   ،6  ورودی آنالوگ دارد که ازA4  تاA5  نامگذاری شده

بیت می  44هر یک از پین ها تا   میزان تفکیک پذیری. اند

ولت را  5تا  4ی یعنی بازه مقدار مختلف4401به عنوان)باشد

به صورت پیش فرض این پین ها (. کنندقسمت تقسیم می 4401به 

ولت 5تا حداکثر ( Ground)می توانند ولتاژی بین ولتاژ پایه 

و  AREFپین ولی با استفاده از . را اندازه گیری نمایند

تغییر حد بالای میزان تفکیک پذیری امکان  ()analogReference تابع

همچنین بعضی از پین ها دارای عملکردهای . پذیر می باشد

 :منحصر به فردی می باشند که شرح آن در ذیل آمده است

 TWI :  پینA1  یاSDA  وA5  یاSCL : این پین ها امکان

توابع کتابخانه  را با استفاده از TWIایجاد یک ارتباط 

 .مقدور می سازند Wireای 

 :سایر پین ها

 AREF: ولتاژ مرجع برای ورودی های آنالوگ، از طریق این

تأمین می  ()analogReference پین و با استفاده از تابع

 .گردد

 Reset: وضعیت لاین مرتبط را برای ریست میکروکنترلر در

قرار می دهد، معمولًا زمانی از این پین  Lowحالت 

استفاده می شود که بخواهید بر روی شیلدتان دکمه ریست 

http://arduino.cc/en/Reference/AnalogReference
http://arduino.cc/en/Reference/Wire
http://arduino.cc/en/Reference/Wire
http://arduino.cc/en/Reference/Wire
http://arduino.cc/en/Reference/AnalogReference
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استفاده از شیلدها از دسترسی به دکمه  زیرا. قرار دهید

 .ریست موجود بر روی برد آردوینو جلوگیری می کند

 

به  USBکافی است آن را با کابل  Unoبرای شروع کار با 

ی کامپیوتر خود متصل نموده و بعد از اتصال یک بار دکمه

 .قرمز رنگ موجود روی برد را فشار دهید تا برد ریست شود

 

 

 

 : نويسی آردوينو برنامه

های نویسی در محیط آردوینو برای بردبرای شروع کار برنامه

برای .  این شرکت ابتدا باید کامپایلر آن را دانلود کنید 

این کار از لینک زیر  استفاده کنید و یا از سرور دانشکده 

 .مکانیک آن را بردارید

 برای مک  برای ویندوز

توجه داشته باشید که درایورهای مربوطه برای شناخت بردهای 

شود و لذا بعد از همراه فایل نصبی فوق ، نصب می آردوینو

را به کامپیوتر  Unoثلا نصب برنامه اگر یک برد آردوینو م

اگر نشناخت .خود وصل کنید باید کامپیوتر آن را بشناسد

 :مراحل زیر را دنبال کنید 

  روی منویStart  کلیک کرده وControl Panel را باز نمایید. 

   در پنجرهControl Panel  بهSystem and Security سپس، . بروید

بالا آمد،  Systemزمانی که پنجره .. کلیک کنید Systemروی 

Device Manager را باز کنید. 

http://downloads.arduino.cc/arduino-1.0.6-windows.exe?AWSAccessKeyId=hKqOiStmqc_Y3-9k2xue&Expires=1418016130&Signature=HkoyJD2CsXuAim7atMXI%2FDOfY%2Bg%3D&response-content-disposition=attachment;filename=arduino-1.0.6-windows.exe
http://downloads.arduino.cc/arduino-1.0.6-windows.exe?AWSAccessKeyId=hKqOiStmqc_Y3-9k2xue&Expires=1418016130&Signature=HkoyJD2CsXuAim7atMXI%2FDOfY%2Bg%3D&response-content-disposition=attachment;filename=arduino-1.0.6-windows.exe
http://downloads.arduino.cc/arduino-1.0.6-macosx.zip?AWSAccessKeyId=hKqOiStmqc_Y3-9k2xue&Expires=1418016181&Signature=Y9xWQrVSKgOhPLJgYHH72tN4EO4%3D&response-content-disposition=attachment;filename=arduino-1.0.6-macosx.zip
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  زیر Ports (Com & LPT) باید یک پورت باز به . را نگاه کنید

 .ببینید" Arduino UNO (COMxx)"نام 

 روی پورت "Arduino UNO (COmxx)"  کنید و گزینه راست کلیک

"Update Driver Software "را انتخاب نمایید. 

  سپس، گزینه"Browse my computer for Driver software " را انتخاب

 .کنید

 ،و فایل راه انداز را  به مسیر برنامه رفته در نهایت

نرم افزار " Drivers"که در پوشه  "arduino.inf" به نام

 FTDI USB"زیرشاخه . ) یدانتخاب نمای ،آردوینو قرار دارد
Drivers .)"محیط برنامه نویسی اگر از یک نسخه قدیمی  (

استفاده می کنید، فایل راه انداز ( یا قدیمی تر 4.4.3

Uno را با نام "Arduino UNO.inf"انتخاب کنید. 

 

چراغ سبز )پس از نصب برنامه و نیز اتصال برد به کامپیوتر 

مشخص شده است باید روشن  PWR برچسبکه با  رنگ مربوط به منبع

 :شوید با محیط زیر مواجه می( شود
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ی بعدی باید از بین بردهای آردوینو مختلف موجود ، در مرحله

برد خود را که به کامپیوتر متصل کرده و قصد کار با آن را 

انتخاب  Tools > Board از منویآن را دارید مشخص کنید 

 (انتخاب نمایید Arduino Unoشما همان گزینه اول یعنی ).کنید
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سپس یابد پورت سریالی که کامپیوتر تحت آن آردوینو را 

 پورت سریال برد آردوینو خود را از منوی .شناخته معین کنید

Tools > Serial Port این گزینه احتمالاً . انتخاب کنید COM3  یا بالاتر

برای پورت های سریال سخت افزاری معمولًا  COM2 و COM1 )است

آن، شما می  پورت مربوط به برای دانستن(. رزرو شده اند

و  از کامپیوتر بیرون کشیده توانید برد آردوینو خود را

مجدداً منو را باز نمایید؛ پورتی که این بار نشان داده نمی 

برد را مجدداً متصل کنید و آن پورت . شود، برد آردوینو است

کامپیوترتان آن  Device managerیا از ).انتخاب نمایید سریال را

 (را پیدا کنید
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نوع پروگرامر را  Tools > Programmerدر مرحله آخر از منوی 

Arduino as ISP انتخاب کنید. 

  یتوانید هر کدی که نوشته اید را با فشردن دکمهحال می

upload  که  توجه داشته باشید. روی برد خود پروگرام نمایید

اگر عمل پروگرام کردن به درستی انجام شود مطابق تصویر زیر 

شوید وگرنه در قسمت مشکی مواجه می Done Uploadingبا پیغام 

.رنگ پایین برنامه با پیغام خطا مواجه خواهید شد

 

 

 

 : ی کدنويسی در آردوينو نحوه

توان گفت ادبیات کدنویسی در آردوینو تا حد به طور کلی می

ی قابل اتکا در نکته. باشد می ++Cبسیار زیادی مشابه زبان 
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یک راهنمای بسیار جامع و کامل مورد آردوینو این است که 

ای ارائه داده که ها و توابع حرفهاز مبتدی تا تمام کلاس

ن راهنما ای. برای هر کسی با هر سطح اطلاعات کاملاً کارگشاست 

و یا داخل  Learning > Referenceاز طریق سایت آردوینو بخش 

قابل دسترسی و مطالعه  Help > Referenceی آردوینو منوی برنامه

در نرم افزار یا بخش  File > Exampleهمچنین در منوی . است

Learning > Example  در سایت تعداد زیادی مثال نوشته شده که

برای استفاده  ، موجود است ربردی هستندبسیار نیز مفید و کا

موجود است که برای  های میکرو کدهای متعددتمام قسمت از

 .ها کار کنیدتوانید روی آنآشنایی می

تر که در چند تابع مهمبه ما در اینجا به عنوان نمونه 

 :کنیم نیز مورد نیاز است اشاره می هاآزمایش

که  setup() voidکدهای آردوینو شامل دو بخش اصلی است یکی تابع 

اندازی درگاه سریال و های اولیه مثل راهدر آن مقداردهی

شود این انجام می... مقداردهی های اولیه به متغیرها و 

روشن شدن یا ریست )تابع تنها یکبار هنگام شروع کار میکرو 

 . شود اجرا می( شدن

است که این تابع مشابه  ()void loopتابع  تابع اصلی دیگر

while(1)  درcode vision  ًاست ، این تابع در طی کار میکرو مداما

شود که اصل کار میکرو صدا شده و کدهای درون آن اجرا می

 .است

تواند ها را مینوع پین pinMode(pin num , output or input)تابع 

 .تعیین کند

های آنالوگ مقدار آنالوگ را از ورودی analogRead (pin num)تابع

 .کندمی(  4401تا  4عددی بین )خوانده و تبدیل به دیجیتال 
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-یک پین را صفر یا یک می digitalWrite(pin num , HIGH or LOW)تابع 

 .کند

با واحد میلی ثانیه تاخیر  numبه اندازه  delay(num)تابع 

 .کندایجاد می

آن را  duty cycleکه  PWMیک موج  analogWrite(pin num , value)تابع 

num کند مروی پین هایی که خاصیت مشخص میPWM  را دارند

 . کند ایجاد می

           
   

   
 

هایی که در فقط آن پین Unoتوجه داشته باشید که روی برد   *

را دارا  PWMدارند قابلیت تولید  ~شان علامت کنار شماره

 .هستند

کردن  includeلازم به ذکر است هیچ یک از توابع فوق نیازی به *

 .ی خاصی ندارندکتابخانه

تر در مورد توابع فوق و برای کسب اطلاعات کاملتر و دقیق*

آردوینو  referenceدیگر توابع مورد استفاده در کد نویسی به 

 .مراجعه کنید

 

 

 

 

 

 


